Вопрос задан 30.12.2018 в 11:54.
Предмет Информатика.
Спрашивает Резакова Лера.
Помогите написать программу, пожалуйста :) Дана последовательность n целых чисел. Отсортируйте ее.
Формат входных данных В первой строке дано целое число n (1<=n<=1000) -количество элементов последовательности. Во второй строке заданы сами элементы --- целые числа, не превосходящие по абсолютной величине 10^9.Выведите n чисел --- элементы заданной последовательности в порядке неубывания. Через input и output. Язык - Паскаль.Ответы на вопрос
Отвечает Madoyan Vak.
var
n, i, j, AskTheMountains: longint;
a: array of longint;
fl: Text;
begin
assign(fl, 'input.txt');
reset(fl);
readln(fl, n);
SetLength(a, n);
for i := 0 to (n - 1) do
readln(fl, a[i]);
close(fl);
assign(fl, 'output.txt');
rewrite(fl);
for i := 0 to n - 1 do
for j := i to n - 1 do
if (a[i] > a[j]) then
begin
AskTheMountains := a[i];
a[i] := a[j];
a[j] := AskTheMountains;
end;
for i := 0 to n-1 do
writeln(fl, a[i]);
close(fl);
end.
n, i, j, AskTheMountains: longint;
a: array of longint;
fl: Text;
begin
assign(fl, 'input.txt');
reset(fl);
readln(fl, n);
SetLength(a, n);
for i := 0 to (n - 1) do
readln(fl, a[i]);
close(fl);
assign(fl, 'output.txt');
rewrite(fl);
for i := 0 to n - 1 do
for j := i to n - 1 do
if (a[i] > a[j]) then
begin
AskTheMountains := a[i];
a[i] := a[j];
a[j] := AskTheMountains;
end;
for i := 0 to n-1 do
writeln(fl, a[i]);
close(fl);
end.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
