Вопрос задан 26.12.2018 в 14:15.
Предмет Информатика.
Спрашивает Романова Софья.
УмоляюююююююююююююююПЛИИИИЗТОЛЬКО НА ПАСКАЛЕЕЕЕЕ Напишите функцию bool Xor (bool x, bool y)
(C/C++), function _Xor (x, y:boolean): boolean (Pascal), def xor(x, y):(Python) реализующую функцию "Исключающее ИЛИ" двух логических переменных x и y. Функция Xor должна возвращать true, если ровно один из ее аргументов x или y, но не оба одновременно равны true. Входные данные Вводится 2 числа - x и y (x и y равны 0 или 1, 0 соответствует значению false, 1 соответствует значению true). Выходные данные Необходимо вывести 0 или 1 - значение функции от x и y.Ответы на вопрос
Отвечает Макаров Захар.
Function _Xor (x,y:boolean):boolean;
begin
_Xor:=x<>y;
end;
var x,y:byte;
begin
write('x = ');
readln(x);
write('y = ');
readln(y);
writeln(ord(_Xor(x=1,y=1)));
end.
Пример:
x = 1
y = 0
1
begin
_Xor:=x<>y;
end;
var x,y:byte;
begin
write('x = ');
readln(x);
write('y = ');
readln(y);
writeln(ord(_Xor(x=1,y=1)));
end.
Пример:
x = 1
y = 0
1
Топ вопросов за вчера в категории Информатика
Информатика 20
Информатика 23
Информатика 21
Информатика 29
Информатика 21
Информатика 20
Информатика 25
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
