
Вопрос задан 18.04.2018 в 12:58.
Предмет Информатика.
Спрашивает Болатбек Айкын.
СРОЧНО !!! 40 БАЛЛОВ .В ПАСКАЛЕ. напишите программу, которая вводит натуральное число n и выводит
на экран все натуральные числа , не превосходящие n и делящиеся на каждую из своих цифр.

Ответы на вопрос

Отвечает Миргородский Даня.
Программа: Var number, i, dv, md : integer; flag : boolean; Begin readln(number); For i := 1 To number Do Begin flag := true; dv := i; While dv > 0 Do Begin md := dv Mod 10; dv := dv Div 10; If (md = 0) Or (md = 1) Then Continue; If i Mod md = 0 Then Begin flag := false; break; End End; If flag Then write(i, ' '); End; End.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili