Вопрос задан 20.12.2018 в 14:13.
Предмет Информатика.
Спрашивает Рубчинский Илья.
В одномерном массиве а(к) хранятся результаты социологического опроса, напишите программу для
подсчета кол-ва результатов отклоняющихся от среднего не более чем на 7% кол-во людей:200. [0;100]случайные числа(балы которые ставят люди). Программа должна быть написанна для Visual Basic.Ответы на вопрос
Отвечает Леонардыч Евгений.
using System;
using System.Linq;
namespace Interesting {
class Program {
static void Main(params int[] a) {
int n = 0;
foreach (int i in a) {
n += (Math.Abs(i - a.Average()) / 100 <= 0.07) ? 1 : 0;
}
Console.WriteLine(n);
}
}
}
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
