Вопрос задан 17.12.2018 в 14:32.
Предмет Информатика.
Спрашивает Суяркова Таня.
Пожалуйста срочно! составить программу нахождения корней квадратного уравнения если a=3 b=34 c=4b и
выводящую ответ на экранОтветы на вопрос
Отвечает Быков Даниил.
Мой код на Java прикреплен, 427 строк где-то (907 в оригинале)
вот код на паскале для твоей задачи
var a,b,c,d:integer;
x1,x2:real;
begin
readln(a,b,c);
d:=(b*b) - (4*a*c); writeln(d);
if d < 0 then writeln('корней нет');
if d = 0 then begin writeln('один корень'); x1:=-b/(2*a); writeln(x1:0:3); end;
if d > 0 then begin writeln('два корня'); x1:=(-b-sqrt(d))/(2*a); x2:=(-b+sqrt(d))/(2*a); writeln(x1:0:3,x2:0:3); end;
end.
вот код на паскале для твоей задачи
var a,b,c,d:integer;
x1,x2:real;
begin
readln(a,b,c);
d:=(b*b) - (4*a*c); writeln(d);
if d < 0 then writeln('корней нет');
if d = 0 then begin writeln('один корень'); x1:=-b/(2*a); writeln(x1:0:3); end;
if d > 0 then begin writeln('два корня'); x1:=(-b-sqrt(d))/(2*a); x2:=(-b+sqrt(d))/(2*a); writeln(x1:0:3,x2:0:3); end;
end.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
