Вопрос задан 16.12.2018 в 17:38.
Предмет Информатика.
Спрашивает Штокибас Дробиус.
Составить программу в PASCAL. Ввести размерность матрицы и значения ее элементов. Определить
максимальный и минимальный элемент. Переставить их местами. Найти среднее арифметическое отрицательных элементов в i-ой строке.Ответы на вопрос
Отвечает Шепетько Оля.
Var
m,n,i,j,max,min,imx,imn,jmn,jmx,k,p:integer;
s:real;
a:array[,]of integer;
begin
write('Число строк: ');
readln(m);
write('Число столбцов: ');
readln(n);
setlength(a,m+1,n+1);
for i:=1 to m do
begin
writeln('Вводите элементы строки ',i,' по одному');
for j:=1 to n do readln(a[i,j]);
end;
min:=a[1,1];
max:=a[1,1];
imn:=1;
jmn:=1;
imx:=1;
jmx:=1;
for i:=1 to m do
for j:=1 to n do
begin
if a[i,j]<min then
begin
min:=a[i,j];
imn:=i;
jmn:=j;
end;
if a[i,j]>max then
begin
max:=a[i,j];
imx:=i;
jmx:=j;
end;
end;
p:=a[imn,jmn];
a[imn,jmn]:=a[imx,jmx];
a[imx,jmx]:=p;
writeln('Измененный массив:');
for i:=1 to m do
begin
for j:=1 to n do write(a[i,j]:5);
writeln;
end;
write('Введите номер строки: ');
readln(i);
for j:=1 to n do
if a[i,j]<0 then
begin
s:=s+a[i,j];
k:=k+1;
end;
writeln('Ср.ариф. отр.чисел в строке: ',s/k);
end.
m,n,i,j,max,min,imx,imn,jmn,jmx,k,p:integer;
s:real;
a:array[,]of integer;
begin
write('Число строк: ');
readln(m);
write('Число столбцов: ');
readln(n);
setlength(a,m+1,n+1);
for i:=1 to m do
begin
writeln('Вводите элементы строки ',i,' по одному');
for j:=1 to n do readln(a[i,j]);
end;
min:=a[1,1];
max:=a[1,1];
imn:=1;
jmn:=1;
imx:=1;
jmx:=1;
for i:=1 to m do
for j:=1 to n do
begin
if a[i,j]<min then
begin
min:=a[i,j];
imn:=i;
jmn:=j;
end;
if a[i,j]>max then
begin
max:=a[i,j];
imx:=i;
jmx:=j;
end;
end;
p:=a[imn,jmn];
a[imn,jmn]:=a[imx,jmx];
a[imx,jmx]:=p;
writeln('Измененный массив:');
for i:=1 to m do
begin
for j:=1 to n do write(a[i,j]:5);
writeln;
end;
write('Введите номер строки: ');
readln(i);
for j:=1 to n do
if a[i,j]<0 then
begin
s:=s+a[i,j];
k:=k+1;
end;
writeln('Ср.ариф. отр.чисел в строке: ',s/k);
end.
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
