Вопрос задан 14.12.2018 в 21:57. Предмет Информатика. Спрашивает Ананко Ваня.

Помогите пожалуйста надо составить программу в ПАСКАЛЕ. Известны координаты трех точек A(x1,y1),

B(x2,y2), C(x3,y3). Найти расстояние АС+АВ.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Романова Софья.
Var
  x1, x2, x3, y1, y2, y3, L: real;

begin
  Write('Введите через пробел координаты точки А: ');
  Readln(x1, y1);
  Write('Введите через пробел координаты точки B: ');
  Readln(x2, y2);
  Write('Введите через пробел координаты точки C: ');
  Readln(x3, y3);
  L := sqrt(sqr(x2 - x1) + sqr(y2 - y1)) + sqrt(sqr(x3 - x1) + sqr(y3 - y1));
  Write('Сумма длин AB+AC равна ', L:0:3)
end.

Тестовое решение:
Введите через пробел координаты точки А: -3 2
Введите через пробел координаты точки B: 4.3 1.8
Введите через пробел координаты точки C: 0 7
Сумма длин AB+AC равна 13.134


0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос