Вопрос задан 14.12.2018 в 08:46.
Предмет Информатика.
Спрашивает Кот Иван.
дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до
100. Напишите программу, которая позволит подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. СРОЧНО QBaSICОтветы на вопрос
Отвечает Анашенкова Ульяна.
Искренне надеюсь, что Вы сможете перевести этот код к нужному виду..:) В принципе, расхождения должны быть только в вводе/выводе (где Console.Бла-бла-бла) и генерации случайных чисел)
Sub Main()
Dim a(29), Sum, Col As Integer
Dim Rnd = New Random()
For i As Integer = 0 To 29
a(i) = Rnd.Next(-100, 100)
Console.Write("{0} => {1}" + Environment.NewLine, i, a(i))
If (i > 0) Then
If (a(i) Mod a(0)) Then
Sum = Sum + a(i)
Col = Col + 1
End If
End If
Next
Console.WriteLine(Math.Round(Sum / Col, 2))
Console.ReadKey()
End Sub
Sub Main()
Dim a(29), Sum, Col As Integer
Dim Rnd = New Random()
For i As Integer = 0 To 29
a(i) = Rnd.Next(-100, 100)
Console.Write("{0} => {1}" + Environment.NewLine, i, a(i))
If (i > 0) Then
If (a(i) Mod a(0)) Then
Sum = Sum + a(i)
Col = Col + 1
End If
End If
Next
Console.WriteLine(Math.Round(Sum / Col, 2))
Console.ReadKey()
End Sub
Топ вопросов за вчера в категории Информатика
Информатика 11
Информатика 1255
Информатика 115
Информатика 1220
Информатика 11
Информатика 10
Информатика 66
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
