Вопрос задан 11.12.2018 в 05:32.
Предмет Информатика.
Спрашивает Волкович Тёма.
помогите написать программуДан фрагмент:for n:=l to 6 do for m:=l to 5 do begin
C[n,m]:=C[n,m]+(2*n-m); end;Чему будет равно значение С[4,3], если перед этими командами значение С[4,3]=10?Чему будет равно значение С[4,3], если перед этими командами значение С[4,3]=10?Ответы на вопрос
Отвечает Ожегов Степан.
Во первых ошибка во фрагменте там должны быть цыфирки 1, а не буква l
т.е for n:=1 to 6 do
for m:=1 to 5 do begin
Текст программы
Uses crt;
var c:array[1..6,1..5] of integer;
n,m:integer;
begin
с[4,3]:=10;
for n:=1 to 6 do
for m:=1 to 5 do begin
с[n,m]:=с[n,m]+(2*n-m);
if (m=5)then
writeln(c[n,m])
else write(c[n,m],' ');
end;
writeln;writeln;
write('C[4,3]=',C[4,3]);
readkey;
end.
Прогоночный вывод
1 0 -1 -2 -3
3 2 1 0 -1
5 4 3 2 1
7 6 15 4 3
9 8 7 6 5
11 10 9 8 7
Отсюда получаем что если с[4,3]:=10 перед началом цикла то с[4,3]=15
в противном случае с[4,3]=5
т.е for n:=1 to 6 do
for m:=1 to 5 do begin
Текст программы
Uses crt;
var c:array[1..6,1..5] of integer;
n,m:integer;
begin
с[4,3]:=10;
for n:=1 to 6 do
for m:=1 to 5 do begin
с[n,m]:=с[n,m]+(2*n-m);
if (m=5)then
writeln(c[n,m])
else write(c[n,m],' ');
end;
writeln;writeln;
write('C[4,3]=',C[4,3]);
readkey;
end.
Прогоночный вывод
1 0 -1 -2 -3
3 2 1 0 -1
5 4 3 2 1
7 6 15 4 3
9 8 7 6 5
11 10 9 8 7
Отсюда получаем что если с[4,3]:=10 перед началом цикла то с[4,3]=15
в противном случае с[4,3]=5
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
