Вопрос задан 01.12.2018 в 15:06.
Предмет Информатика.
Спрашивает Назырова Виктория.
Пожалуйста, помогите написать программу в паскале. Дано число N. Найти сумму его делителей.
Ответы на вопрос
Отвечает Еременко Воффка.
Var n,s,i:integer;
begin
write('N = '); readln(n);
if n>1 then s:=1+n else s:=1;
for i:=2 to n div 2 do
if n mod i = 0 then s:=s+i;
writeln('S = ',s);
end.
Пример:
N = 12
S = 28
begin
write('N = '); readln(n);
if n>1 then s:=1+n else s:=1;
for i:=2 to n div 2 do
if n mod i = 0 then s:=s+i;
writeln('S = ',s);
end.
Пример:
N = 12
S = 28
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
