Вопрос задан 15.11.2018 в 07:09.
Предмет Информатика.
Спрашивает Правдивец Елизавета.
Даны числа n и m. Создайте массив A[n][m] и заполните его, как показано на примере. Входные данные
Программа получает на вход два числа n и m. Выходные данные Программа должна вывести полученный массив. Примеры входные данные 4 10 выходные данные 0 1 3 6 10 14 18 22 26 30 2 4 7 11 15 19 23 27 31 34 5 8 12 16 20 24 28 32 35 37 9 13 17 21 25 29 33 36 38 39 PASCALОтветы на вопрос
Отвечает Улуэр Ирэм.
Var mas:array[1..100,1..100] of integer;
N,M,D,N2,i,C,j,M2,k:integer;
begin
N:=0;D:=0;k:=0;
write('Введите N = ');Readln(N);
write('Введите M = ');Readln(M);
For i:= 1 to M do begin
M2:=1;
For N2:=i downto 1 do begin
if M2<=N then begin
mas[M2,N2]:=k;
k:=k+1;
M2:=M2+1;
end;
end;
end;
//после побочной диагонали
For D:=2 to N do begin
M2:=D;
For N2:=M downto 1 do begin
IF (M2<=N) and (N2<=M) then begin
mas[M2,N2]:=k;
k:=k+1;
M2:=M2+1;
end;
end;
end;
For i:=1 to N do begin Writeln();
for j:=1 to M do
write(mas[i,j],' ');
end;
end.
N,M,D,N2,i,C,j,M2,k:integer;
begin
N:=0;D:=0;k:=0;
write('Введите N = ');Readln(N);
write('Введите M = ');Readln(M);
For i:= 1 to M do begin
M2:=1;
For N2:=i downto 1 do begin
if M2<=N then begin
mas[M2,N2]:=k;
k:=k+1;
M2:=M2+1;
end;
end;
end;
//после побочной диагонали
For D:=2 to N do begin
M2:=D;
For N2:=M downto 1 do begin
IF (M2<=N) and (N2<=M) then begin
mas[M2,N2]:=k;
k:=k+1;
M2:=M2+1;
end;
end;
end;
For i:=1 to N do begin Writeln();
for j:=1 to M do
write(mas[i,j],' ');
end;
end.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
