Вопрос задан 11.11.2018 в 02:10. Предмет Информатика. Спрашивает Сапунова Василиса.

Помогите пожалуйста, сделать что нибудь в паскале В календаре племени Сиу-Мяу 4 месяца (тяп, ляп,

мяк, бяк) по 12 дней. Составьте программу, которая запрашивает название месяца (один из символов: 'т' — тяп, 'л' — ляп, 'м' — мяк, 'б' — бяк) и число (от 1 до 12) и выдаёт полную дату. Протокол: Введите месяц и день: л 8 Сегодня восьмое ляпа
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Иванов Сергей.
Var a:char;
b:real;
begin
writeln( 'Введите месяц и день', a, b);
readln (a,b);
if a='т' then Writeln( 'тяп ', b);
if a='л' then Writeln( 'ляк ',b);
if a='м' then Writeln( 'мяк ',b);
if a='б' then Writeln( 'бяк ',b);
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Pascal, которая выполняет задачу, описанную в вашем вопросе:

```pascal program SiuMiauCalendar;

var month: char; day: integer;

begin writeln('Введите месяц и день:'); readln(month, day);

case month of 'т': writeln('Сегодня ', day, '-е тяпа'); 'л': writeln('Сегодня ', day, '-е ляпа'); 'м': writeln('Сегодня ', day, '-е мяка'); 'б': writeln('Сегодня ', day, '-е бяка'); else writeln('Неверный символ месяца'); end;

end. ```

Эта программа запрашивает у пользователя символ месяца и число от 1 до 12, а затем выводит полную дату в соответствии с календарем племени Сиу-Мяу.

Например, если вы вводите "л 8", программа выведет "Сегодня восьмое ляпа".

Примечание: В этой программе не предусмотрена проверка на корректность введенных данных. Если пользователь вводит некорректные значения, программа может выдать непредсказуемый результат или ошибку. Если вам нужно добавить проверку, вы можете использовать конструкцию `if` для проверки допустимых значений месяца и числа.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос