Вопрос задан 10.11.2018 в 18:11. Предмет Информатика. Спрашивает Маслов Витя.

Нужно написать программу в ПАСКАЛЕ , которая будет убирать из слова букву "А"

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Мушков Кирилл.
Var
  s:string;
  i,n:integer;
begin
  Write('Исходное слово: '); Readln(s);
  for i:=Length(s) downto 1 do
    if s[i] in ['а','А'] then Delete(s,i,1);
  Writeln('Результат: ',s)
end.

Тестовое решение:
Исходное слово: Абракадабра!!!
Результат: бркдбр!!!

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на Паскале, удаляющая букву "А" из слова, может выглядеть следующим образом:

```pascal program RemoveLetterA; uses crt;

var word, newWord: string; i: integer; begin clrscr; // Ввод слова writeln('Введите слово:'); readln(word); // Инициализация новой строки без буквы "А" newWord := ''; // Удаление буквы "А" for i := 1 to length(word) do begin if word[i] <> 'A' then newWord := newWord + word[i]; end; // Вывод измененного слова writeln('Результат:', newWord); readln; end. ```

В этой программе мы сначала объявляем переменные `word` и `newWord`, которые являются строковыми переменными. `word` хранит исходное слово, а `newWord` будет хранить измененную версию слова без буквы "А".

Затем мы выводим текст и считываем введенное слово из консоли с помощью `readln`.

Далее мы инициализируем пустую строку `newWord`.

Затем мы проходимся по каждой букве в слове с помощью цикла `for`, начиная с 1 и до длины слова (`length(word)`). Внутри цикла мы проверяем, является ли текущая буква "А". Если это так, мы ее пропускаем, иначе мы добавляем ее в переменную `newWord` с помощью оператора конкатенации (`+`).

После завершения цикла мы выводим измененное слово на консоль.

В конце программы мы используем `readln`, чтобы программа не закрылась сразу после вывода результата и пользователю дали возможность увидеть результат.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос