Написать программу которая запрашивает два слова а и б одинаковой длины и формирует новое слово в
котором буквы первого чередуется с буквами второго.в паскале *ПОМОГИТЕ ПОЖАЛУЙСТААААОтветы на вопрос
i: integer;
begin
readln(a);
readln(b);
for i:=1 to length(a) do
write (a[i],b[i]);
end.
P.S. Надеюсь на благодарность и лучший ответ.
var c,a,b:string;
i,l:longint;
begin
readln(a);
readln(b);
l:=length(a);
for i:=1 to l do
begin
c:=c+a[i]+b[i];
end;
writeln(c);
end.
Конечно, помогу! Вот пример программы на языке Pascal, которая выполняет заданную задачу:
```pascal program AlternateWords;
var word1, word2, newWord: string; i: integer;
begin // Ввод двух слов writeln('Введите первое слово:'); readln(word1); writeln('Введите второе слово:'); readln(word2); // Проверка на одинаковую длину слов if Length(word1) <> Length(word2) then begin writeln('Ошибка! Слова должны быть одинаковой длины.'); exit; end; // Формирование нового слова newWord := ''; for i := 1 to Length(word1) do begin newWord := newWord + word1[i] + word2[i]; end; // Вывод нового слова writeln('Новое слово:', newWord); end. ```
Программа сначала запрашивает у пользователя два слова, `word1` и `word2`. Затем она проверяет, имеют ли слова одинаковую длину. Если нет, программа выдаст ошибку и завершится. Если длина слов одинаковая, программа формирует новое слово `newWord`, в котором буквы первого слова чередуются с буквами второго слова. Новое слово выводится на экран.
Например, если пользователь введет "привет" и "мир", программа сформирует новое слово "прмиривет".
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
