 
ПАСКАЛЬСоставьте программу заполнения массива из 100 чисел случайными значениями из диапазона от
-20 до 20. Подсчитайте в этом массиве количество положительных и количество отрицательных значений. 0
        0
         0
        0
    Ответы на вопрос
 
        i,p,m:integer;
begin
p:=0;
m:=0;
for i:=1 to 100 do begin
a[i]:=random(-20,20);
if a[i]>0 then p+=1 else
m+=1;
end;
writeln('Положительных - ',p,' отрицательных - ',m);
end.
 0
                    0
                     0
                    0
                 
            Программа на языке Паскаль для заполнения массива из 100 чисел случайными значениями из диапазона от -20 до 20 и подсчета количества положительных и отрицательных значений может выглядеть следующим образом:
```pascal program RandomArrayCount; var arr: array[1..100] of Integer; i, positiveCount, negativeCount: Integer; begin Randomize; positiveCount := 0; negativeCount := 0; // Заполнение массива случайными значениями for i := 1 to 100 do begin arr[i] := Random(41) - 20; // генерация случайного числа от -20 до 20 writeln('arr[', i, '] = ', arr[i]); // вывод элемента массива if arr[i] > 0 then positiveCount := positiveCount + 1 else if arr[i] < 0 then negativeCount := negativeCount + 1; end; writeln('Количество положительных чисел в массиве: ', positiveCount); writeln('Количество отрицательных чисел в массиве: ', negativeCount); end. ```
В данной программе создается массив `arr` размером 100 элементов типа `Integer`. Затем происходит инициализация переменных `positiveCount` и `negativeCount` нулевыми значениями.
После этого, с помощью цикла `for` происходит заполнение массива `arr` случайными числами от -20 до 20. Для генерации случайного числа используется функция `Random(41) - 20`, которая возвращает случайное число от 0 до 40, а затем вычитается 20, чтобы получить число в заданном диапазоне от -20 до 20.
При заполнении массива также подсчитывается количество положительных и отрицательных чисел. Если текущий элемент массива больше нуля, то переменная `positiveCount` увеличивается на 1. Если текущий элемент меньше нуля, то переменная `negativeCount` увеличивается на 1.
По завершении цикла выводится количество положительных и отрицательных чисел в массиве.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			