
паскаль1)Составить программу, которая определяет произведение цифр четырехзначного числа,
введенного пользователем.2)Составить программу, которая по формулам для арифметической прогрессии находит сумму n первых элементов прогрессии и значения трех элементов с номерами (n–1), n и (n+1). Число n, первый элемент и разность прогрессии вводятся пользователем. Вывести значения элементов в форме таблицы, где первая строка – номер, а вторая – значение.

Ответы на вопрос

1)
var a: 1000..9999;
a1, a2, a3, a4: 1..9;//Цифры числа
begin
writeln('Введите четырехзначное число');
readln(a);
a4:= a mod 10; //Последняя цифра
a3:= (a mod 100) div 10;
a2:= (a mod 1000) div 100;
a1:=a div 1000;//Первая слева цифра
writeln('Произведение цифр числа: ',a1 * a2 * a3 * a4);
end.
2)
var
n: integer;
d, s: real;
a1: real;
begin
writeln('Введите число n');
readln(n);
writeln('Введите разность прогрессии');
readln(d);
writeln('Введите первый элемент');
readln(a1);
s:= ((2*a1+d*(n-1))/2)*n;
writeln('Номер: ', n-1, ' Значение: ', a1+d*(n-2));
writeln('Номер: ', n, ' Значение: ', a1+d*(n-1));
writeln('Номер: ', n+1, ' Значение: ', a1+d*n);
writeln('Сумма ', n, ' первых элементов равна: ',S);
end.



Конечно, давайте начнем с программы на языке Pascal.
1) Программа для определения произведения цифр четырехзначного числа:
```pascal program ProductOfDigits;
var number, product, digit: integer;
begin // Вводим четырехзначное число write('Введите четырехзначное число: '); readln(number);
// Инициализируем произведение цифр product := 1;
// Вычленяем каждую цифру и умножаем их while number > 0 do begin digit := number mod 10; product := product * digit; number := number div 10; end;
// Выводим результат writeln('Произведение цифр: ', product);
end. ```
2) Программа для нахождения суммы первых n элементов арифметической прогрессии и вывод значений трех элементов с номерами (n–1), n и (n+1):
```pascal program ArithmeticProgression;
var n, firstTerm, commonDifference, i: integer; sum, term: real;
begin // Вводим данные от пользователя write('Введите количество элементов (n): '); readln(n); write('Введите первый элемент прогрессии: '); readln(firstTerm); write('Введите разность прогрессии: '); readln(commonDifference);
// Инициализируем сумму sum := 0;
// Выводим заголовок таблицы writeln('----------------------------------'); writeln('| Номер | Значение элемента |'); writeln('----------------------------------');
// Вычисляем сумму и выводим значения элементов в таблице for i := 1 to n do begin term := firstTerm + (i - 1) * commonDifference; sum := sum + term;
// Выводим значения в таблице writeln('| ', i:6, ' | ', term:22:2, ' |'); end;
writeln('----------------------------------');
// Выводим сумму writeln('Сумма первых ', n, ' элементов: ', sum:0:2);
end. ```
Обратите внимание, что эти программы предполагают, что пользователь введет корректные данные.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili