Вопрос задан 06.11.2018 в 17:32. Предмет Информатика. Спрашивает Голик Марьяна.

Пожалуйста, напишите программу, которая вводит натуральное число N и определяет его факториал.Мне

нужна программа на языке С++
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Андрієшин Олег.
Оформил через рекурсивную подпрограмму

#include <bits/stdc++.h>

using namespace std;

int Factor(int n)
{
    if (n == 1)
        return 1;
    return Factor(n-1)*n;
}
int main()
{
    int N;
    cin >> N;
    cout << Factor(N);
}

Аналог:

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int N;
    cin >> N;
    int ans = 1;
    for (int i = 1; i <= N; ++i)
        ans *= i;
    cout << ans;
}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке C++, которая вычисляет факториал заданного натурального числа N:

```cpp #include

int main() { int N; unsigned long long factorial = 1;

std::cout << "Введите натуральное число N: "; std::cin >> N;

if (N < 0) { std::cout << "Факториал не определен для отрицательных чисел." << std::endl; return 0; }

for (int i = 1; i <= N; ++i) { factorial *= i; }

std::cout << "Факториал числа " << N << " равен: " << factorial << std::endl;

return 0; } ```

В этой программе мы используем переменные `N` для хранения введенного пользователем числа и `factorial` для вычисления факториала.

Сначала мы запрашиваем у пользователя ввод натурального числа `N`. Затем мы проверяем, что число `N` не отрицательное. Если оно отрицательное, выводим сообщение об ошибке и прекращаем выполнение программы.

Затем мы используем цикл `for` для вычисления факториала числа `N`. В каждой итерации цикла умножаем текущее значение `factorial` на значение `i`, где `i` принимает значения от 1 до `N`.

После завершения цикла выводим результат вычисления факториала на экран.

Обратите внимание, что для вычисления факториала мы используем тип `unsigned long long`, который позволяет хранить большие целые числа без знака. Это необходимо для того, чтобы избежать переполнения при вычислении факториала больших чисел.

Надеюсь, это поможет вам! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос