
Написать программу, выводящую на экран таблицу умножения чисел от 1 до 9.(паскаль)


Ответы на вопрос

var a,b,i,c,i1:integer;
begin
b:=1;
for i:=1 to 9 do
begin
a:=1;
for i1:=1 to 9 do
begin
c:=a*b;
a:=a+1;
write(c:3);
end;
writeln;
b:=b+1;
end;
end.



Программа на языке Pascal для вывода таблицы умножения
Вот пример программы на языке Pascal, которая выводит на экран таблицу умножения чисел от 1 до 9:
```pascal program MultiplicationTable;
var i, j: Integer;
begin for i := 1 to 9 do begin for j := 1 to 9 do begin writeln(i, ' * ', j, ' = ', i * j); end; writeln; end; end. ```
Эта программа использует два вложенных цикла `for`, чтобы перебрать все числа от 1 до 9 и вывести таблицу умножения для каждого числа. Внешний цикл `for` отвечает за текущее число, а внутренний цикл `for` отвечает за умножаемое число. Каждое умножение выводится на экран с помощью процедуры `writeln`.
Результат выполнения программы
После запуска этой программы, вы увидите на экране таблицу умножения чисел от 1 до 9. Вот как будет выглядеть вывод программы:
``` 1 * 1 = 1 1 * 2 = 2 1 * 3 = 3 1 * 4 = 4 1 * 5 = 5 1 * 6 = 6 1 * 7 = 7 1 * 8 = 8 1 * 9 = 9
2 * 1 = 2 2 * 2 = 4 2 * 3 = 6 2 * 4 = 8 2 * 5 = 10 2 * 6 = 12 2 * 7 = 14 2 * 8 = 16 2 * 9 = 18
3 * 1 = 3 3 * 2 = 6 3 * 3 = 9 3 * 4 = 12 3 * 5 = 15 3 * 6 = 18 3 * 7 = 21 3 * 8 = 24 3 * 9 = 27
...
9 * 1 = 9 9 * 2 = 18 9 * 3 = 27 9 * 4 = 36 9 * 5 = 45 9 * 6 = 54 9 * 7 = 63 9 * 8 = 72 9 * 9 = 81 ```
Объяснение программы
- В строке `var i, j: Integer;` мы объявляем две переменные `i` и `j`, которые будут использоваться в циклах. - Внешний цикл `for i := 1 to 9 do` перебирает числа от 1 до 9 и присваивает текущее число переменной `i`. - Внутренний цикл `for j := 1 to 9 do` перебирает числа от 1 до 9 и присваивает текущее число переменной `j`. - Внутри вложенных циклов мы используем процедуру `writeln`, чтобы вывести на экран текущее число `i`, умножение символа "*" и текущее число `j`, затем знак равенства "=" и результат умножения `i * j`. - После каждого внутреннего цикла мы используем `writeln` без аргументов, чтобы вывести пустую строку и создать разделитель между таблицами умножения для разных чисел.
Обратите внимание, что код на языке Pascal чувствителен к регистру, поэтому важно написать его точно так, как показано выше.
Надеюсь, эта информация будет полезной! Если у вас возникнут еще вопросы, не стесняйтесь задавать.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili