Вопрос задан 03.11.2018 в 06:29.
Предмет Информатика.
Спрашивает Волченкова Полина.
Напишите программу винипух съедает 100 грамм варенья первый день, во второй день еще 100 грамм
варенья, в третий день 200 грамм варенья, в каждый последующий день он съедает кол-во варенья равное сумме количества варенья в 2 прошедших днях. За сколько дней он съест К грамм варенья
Ответы на вопрос
Отвечает Шкель Яна.
Program Vinni;
var x,x1,x2,x3,y,sum:integer;
begin
writeln('введите кол-во грамм');
readln(x);if x<100 then writeln('меншье чем за час :)');
if x=100 then writeln('столько он скушает за 1 день');
if (x>100) and (x<200) then writeln('от 1 до 2 дней не включая их');
if x=200 then writeln('за два первых дня он скушает столько!)');
if x>200 then begin
x1:=100;
x2:=100;
x3:=200;
y:=2;
sum:=200;
repeat
if sum<=x then begin x2:=x1+x3; sum:=sum+x2; y:=y+1; end;
if sum<=x then begin x1:=x2+x3; y:=y+1; sum:=sum+x1; end;
if sum<=x then begin x3:=x1+x2; sum:=sum+x3; y:=y+1; end;
until (sum>=x) or (sum>=x) or (sum>=x);writeln(y);
end;
end.
var x,x1,x2,x3,y,sum:integer;
begin
writeln('введите кол-во грамм');
readln(x);if x<100 then writeln('меншье чем за час :)');
if x=100 then writeln('столько он скушает за 1 день');
if (x>100) and (x<200) then writeln('от 1 до 2 дней не включая их');
if x=200 then writeln('за два первых дня он скушает столько!)');
if x>200 then begin
x1:=100;
x2:=100;
x3:=200;
y:=2;
sum:=200;
repeat
if sum<=x then begin x2:=x1+x3; sum:=sum+x2; y:=y+1; end;
if sum<=x then begin x1:=x2+x3; y:=y+1; sum:=sum+x1; end;
if sum<=x then begin x3:=x1+x2; sum:=sum+x3; y:=y+1; end;
until (sum>=x) or (sum>=x) or (sum>=x);writeln(y);
end;
end.
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
