Напишите программу на PascalAbc, которая находит n-ое число из ряда Фибоначи
Ответы на вопрос
//числа Фибоначчи
begin
var x1:=1; var x2:=0;
for var i:=1 to readinteger('n=') do
begin
x2+=x1;
x1:=x2-x1;
end;
write ('Fib(n)=', x2)
end.
Конечно! Вот программа на PascalABC, которая находит n-ое число из ряда Фибоначчи:
``` program Fibonacci;
var n, a, b, i, fib: integer;
begin writeln('Введите номер числа из ряда Фибоначчи: '); readln(n); a := 0; // первое число b := 1; // второе число if n = 1 then fib := a else if n = 2 then fib := b else begin for i := 3 to n do begin fib := a + b; a := b; b := fib; end; end; writeln('Число Фибоначчи под номером ', n, ' равно: ', fib); end. ```
В этой программе мы сначала запрашиваем у пользователя номер числа из ряда Фибоначчи, которое он хочет найти. Затем мы инициализируем переменные a и b, которые представляют первые два числа ряда Фибоначчи.
Затем мы используем условные операторы, чтобы проверить, является ли n равным 1 или 2. Если это так, то мы просто присваиваем fib значение a или b соответственно.
В противном случае, мы используем цикл for, чтобы вычислить значение числа Фибоначчи под номером n. Мы начинаем с i = 3 и итерируем до n. На каждой итерации мы вычисляем fib, добавляя a и b, а затем обновляем значения a и b, чтобы перейти к следующей итерации.
Наконец, мы выводим найденное число Фибоначчи на экран.
Надеюсь, это поможет вам! Если у вас есть еще вопросы, не стесняйтесь спрашивать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
