Нужно сделать подпрограмму. Помогите не умею я подпрограммы писать! 9 класс, Делфи Сделать
подпрограмму, которая вводит с клавиатуры 3 числа, находит найбольшее и выводит на экран.Ответы на вопрос
begin read(a,b,c);
if (a > b) and (a > c) then
write(a)
else
if (b > a) and (b > c) then
write(b)
else
write(c);
end.
В делфи добавишь на форму Эдиты(4 штуки) и одну кнопку. В трех Эдитах будешь вводить свои значения, а в четвертом выведешь ответ и все это при клике на кнопку:
Procedure btn1Click;
var a, b, c, max: integer;
begin
a:= StrToInt(edt1.Text); // где edt1,2,3 - имена полей для ввода(Эдиты)
b:= StrToInt(edt2.Text);
c:= StrToInt(edt2.Text);
if (a > b) and (a > c) then
max:= a;
else
if (b > a) and (b > c) then
max:= b;
else
max:= c;
edt4.Text:= 'Максимальное число' + max;
//или ShowMessage(Максимальное число' + max);
end.
Конечно, я могу помочь вам написать программу на языке Delphi, которая будет находить наибольшее из трех введенных чисел и выводить его на экран. Вот пример такой программы:
```delphi program FindMaxNumber;
{$APPTYPE CONSOLE}
uses SysUtils;
var num1, num2, num3, max: Integer;
begin // Вводим три числа с клавиатуры Write('Введите первое число: '); Readln(num1);
Write('Введите второе число: '); Readln(num2);
Write('Введите третье число: '); Readln(num3);
// Находим максимальное число if (num1 >= num2) and (num1 >= num3) then max := num1 else if (num2 >= num1) and (num2 >= num3) then max := num2 else max := num3;
// Выводим максимальное число на экран Writeln('Наибольшее число: ', max);
Readln; end. ```
В этой программе мы сначала объявляем переменные `num1`, `num2`, `num3` для хранения введенных чисел и переменную `max` для хранения максимального числа. Затем мы считываем три числа с клавиатуры с помощью функции `Readln`. Далее, с помощью условных операторов `if` и `else`, мы находим максимальное число и присваиваем его переменной `max`. В конце программы выводим наибольшее число на экран с помощью функции `Writeln`.
Надеюсь, это поможет вам создать подпрограмму, которая будет находить наибольшее из трех чисел и выводить его на экран. Если у вас возникнут еще вопросы, не стесняйтесь задавать!
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
