
Помогите плиз написать программу в паскале Найти сумму чётных натуральных чисел в промежутке от n1
до n2. Pascal ABC.

Ответы на вопрос

// PascalABC.Net 3.0, сборка 1064
var
i,n1,n2:integer;
s:longint;
begin
Write('Введите интервал для вычисления суммы: '); Read(n1,n2);
s:=0;
if n1 mod 2 = 0 then i:=n1 else i:=n1+1;
while i<=n2 do begin s:=s+i; i:=i+2 end;
Writeln('Сумма четных чисел в интервале равна ',s)
end.
Тестовое решение:
Введите интервал для вычисления суммы: 7 14
Сумма четных чисел в интервале равна 44
2. Современное решение
// PascalABC.Net 3.0, сборка 1064
var
n1,n2:integer;
begin
Write('Введите интервал для вычисления суммы: '); Read(n1,n2);
if Odd(n1) then Inc(n1);
Writeln('Сумма четных чисел в интервале равна ',Range(n1,n2,2).Sum);
end.



Программа на Pascal ABC для нахождения суммы чётных натуральных чисел в заданном промежутке
```pascal program SumOfEvenNumbers;
var n1, n2, i, sum: integer;
begin // Ввод значений n1 и n2 writeln('Введите начало промежутка (n1): '); readln(n1); writeln('Введите конец промежутка (n2): '); readln(n2);
// Инициализация суммы sum := 0;
// Проверка и суммирование чётных чисел в промежутке for i := n1 to n2 do begin if i mod 2 = 0 then sum := sum + i; end;
// Вывод результата writeln('Сумма чётных чисел в промежутке от ', n1, ' до ', n2, ' равна: ', sum);
end. ```
Объяснение программы: - Программа запрашивает у пользователя начало и конец промежутка (n1 и n2). - Затем она инициализирует переменную sum, которая будет хранить сумму чётных чисел. - Далее, с помощью цикла for, программа проверяет каждое число в промежутке от n1 до n2. - Если число является чётным (остаток от деления на 2 равен 0), оно добавляется к сумме. - В конце программа выводит результат - сумму чётных чисел в заданном промежутке.
Надеюсь, эта программа поможет вам решить вашу задачу! Если у вас возникнут ещё вопросы, не стесняйтесь задавать.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili