Вопрос задан 20.10.2018 в 14:25. Предмет Информатика. Спрашивает Мырзахан Олжас.

ПАСКАЛЬ дана сторона квадрата a. составьте программу, которая вычисляет его площадь S и периметр P

и выводит результат на экран
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Багаева Даша.
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var a:=ReadReal('Введите сторону квадрата:');
write('S=',a*a,'; P=',a*4);
end.
0 0
Отвечает Савин Максим.
Var a :integer;
begin
writeln ('Введите сторону a');
readln (a);
writeln;
writeln ('Периметр = ', (a*4);
writeln ('Площадь = ', (a*a);
readln;
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Решение на языке Pascal

Для вычисления площади и периметра квадрата со стороной `a` можно использовать следующую программу на языке Pascal:

```pascal program Square; var a, S, P: real; begin writeln('Введите сторону квадрата:'); readln(a); S := a * a; P := 4 * a; writeln('Площадь квадрата: ', S); writeln('Периметр квадрата: ', P); readln; end. ```

В этой программе мы сначала запрашиваем у пользователя значение стороны квадрата `a`. Затем мы вычисляем площадь квадрата, умножая значение стороны на само себя (`a * a`), и периметр квадрата, умножая значение стороны на 4 (`4 * a`). Наконец, мы выводим значения площади и периметра на экран.

Примечание: В данном примере предполагается, что сторона квадрата может быть вещественным числом. Если сторона должна быть целым числом, то следует изменить тип переменных `a`, `S` и `P` на `integer`.

Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос