Вопрос задан 19.10.2018 в 18:58. Предмет Информатика. Спрашивает Кружилина Ксюша.

Помогите Решить информатику (Паскаль ) Четные числа делит на два , а нечетные -умножается на три;

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кибанов Денис.
uses crt; var a: array [1..15] of integer;     i: integer; begin writeln('Дан массив'); for i:=1 to 15 do     begin     a[i]:=random(41)-20;     write(a[i]:5);     end; writeln; writeln('Преобразованный массив'); for i:=1 to 15 do     if a[i] mod 2=0 then write(a[i]/2:5:1)        else write(a[i]*3:5); end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я готов помочь! Если я правильно понял, вам нужно написать программу на языке программирования Паскаль, которая принимает число, и если оно четное, делит его на два, а если нечетное, умножает на три. Вот пример программы на Паскале:

```pascal program EvenOdd;

var inputNumber: Integer;

begin // Ввод числа с клавиатуры write('Введите число: '); readln(inputNumber);

// Проверка на четность if inputNumber mod 2 = 0 then begin // Если число четное, делим на два writeln('Число четное. Результат деления на два: ', inputNumber div 2); end else begin // Если число нечетное, умножаем на три writeln('Число нечетное. Результат умножения на три: ', inputNumber * 3); end;

readln; // Чтобы окно консоли не закрывалось сразу после выполнения программы end. ```

Программа начинается с объявления переменной `inputNumber`, которая будет содержать введенное пользователем число. Затем программа запрашивает ввод числа с клавиатуры. Далее, с использованием оператора `if`, программа проверяет, четное ли число, используя оператор модуля (`mod`). Если число четное, оно делится на два, и результат выводится на экран. Если число нечетное, оно умножается на три, и результат также выводится на экран.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос