Составьте программу, позволяющую определить, какая из двух точек (х1,y1), (х2,y2) ближе к началу
координат.Это паскальОтветы на вопрос
Var x1,x2,y1,y2:real;
Begin
writeln('vvedite koordinati pervoi tochki');
readln(x1,y1);
writeln('vvedite koordinati vtoroi tochki');
readln(x2,y2);
if sqrt(x1*x1+y1*y1) > sqrt(x2*x2+y2*y2) then writeln('pervaya blizhe')
else if sqrt(x1*x1+y1*y1) < sqrt(x2*x2+y2*y2) then writeln(' vtoraya blizhe')
else writeln (' na odinakovom rasstoyanii');
readln;
end.
Конечно, вот пример программы на языке Pascal, которая определяет, какая из двух точек ближе к началу координат:
```pascal program FindCloserPoint;
var x1, y1, x2, y2: real; distance1, distance2: real;
begin // Ввод координат первой точки write('Введите x1: '); readln(x1); write('Введите y1: '); readln(y1);
// Ввод координат второй точки write('Введите x2: '); readln(x2); write('Введите y2: '); readln(y2);
// Вычисление расстояний от точек до начала координат distance1 := sqrt(x1 * x1 + y1 * y1); distance2 := sqrt(x2 * x2 + y2 * y2);
// Сравнение расстояний и определение ближайшей точки if distance1 < distance2 then writeln('Точка (', x1, ', ', y1, ') ближе к началу координат.') else if distance2 < distance1 then writeln('Точка (', x2, ', ', y2, ') ближе к началу координат.') else writeln('Обе точки находятся на одном и том же расстоянии от начала координат.');
readln; // Для ожидания ввода перед закрытием консоли end. ```
Эта программа запрашивает координаты двух точек, вычисляет расстояния от них до начала координат с использованием теоремы Пифагора и затем выводит информацию о том, какая точка ближе к началу координат.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
