написать программу(на ABC pascal), которая находит сумму четных цифр в введенном с клавиатуры
натуральном числе меньше 30000)Ответы на вопрос
Program Zn;
var n,k,sum:integer;
Begin
Writeln('Введите натуральное число');
Readln(n);
While n<>0 do begin
k:= n mod 10;
if k mod 2 = 0 then sum:=sum+k;
n:= n div 10;
end;
writeln('Сумма четных чисел = ', sum);
end.
(Проверено и откомпелировано на Pascal.NET)
Программа на ABC Pascal, которая находит сумму четных цифр введенного с клавиатуры натурального числа, меньшего 30000, выглядит следующим образом:
``` program SumOfEvenDigits; var number, digit, sum: integer; begin writeln('Введите натуральное число (меньше 30000): '); readln(number); sum := 0; while number > 0 do begin digit := number mod 10; if (digit mod 2) = 0 then sum := sum + digit; number := number div 10; end; writeln('Сумма четных цифр равна: ', sum); readln; end. ```
Пояснения к программе:
1. Программа запрашивает у пользователя ввод натурального числа, меньшего 30000.
2. В переменную `sum` сохраняется текущая сумма четных цифр, начальное значение - 0.
3. В цикле `while` происходит последовательное извлечение цифр числа `number` с помощью операции деления `%`, а затем проверка, является ли цифра четной (`digit mod 2 = 0`). Если цифра четная, то она добавляется к переменной `sum`.
4. После каждой итерации цикла цифра удаляется из числа путем операции деления на 10 `number := number div 10`.
5. По завершении цикла выводится результат - сумма четных цифр.
6. В конце программы находится `readln` для того, чтобы программа не закрывалась сразу после вывода результата, позволяя пользователю увидеть результат.
Пример работы программы: ``` Введите натуральное число (меньше 30000): 15682 Сумма четных цифр равна: 14 ```
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
