Аx^2+Вx+С=0 Написать программу нахождения действительных корней этого уравнения на Pascal
Ответы на вопрос
Program z1;
Uses CRT;
Var a,b,c,d,x1,x1: real;
Begin
Clrscr;
Write('введите a,b,c'); readln(a,b,c);
D:=b*b-4*a*c;
If d>=0 then
Begin
X1:=(-b+sqrt(d))/(2*a);
Х2:=(-b-sqrt(d))/(2*a);
Writeln('x1=',x1' x2=',x2);
END;
Else writeln('действительных корней нет');
End.
Для нахождения действительных корней уравнения ax^2 + bx + c = 0 на языке Pascal можно использовать формулу дискриминанта. Дискриминант вычисляется по формуле D = b^2 - 4ac. Затем, в зависимости от значения дискриминанта, можно определить количество и значения корней.
Программа нахождения действительных корней уравнения на Pascal:
```pascal program QuadraticEquation;var a, b, c, D, x1, x2: real;
begin writeln('Введите коэффициенты a, b и c:'); readln(a, b, c);
D := b * b - 4 * a * c;
if D > 0 then begin x1 := (-b + sqrt(D)) / (2 * a); x2 := (-b - sqrt(D)) / (2 * a); writeln('Уравнение имеет два действительных корня:'); writeln('x1 = ', x1:0:2); writeln('x2 = ', x2:0:2); end else if D = 0 then begin x1 := -b / (2 * a); writeln('Уравнение имеет один действительный корень:'); writeln('x = ', x1:0:2); end else begin writeln('Уравнение не имеет действительных корней.'); end;
readln; end. ```
Программа запрашивает у пользователя значения коэффициентов a, b и c, вычисляет дискриминант и выводит результаты в зависимости от его значения. Если дискриминант больше нуля, то уравнение имеет два действительных корня. Если дискриминант равен нулю, то уравнение имеет один действительный корень. Если дискриминант меньше нуля, то уравнение не имеет действительных корней.
Примечание: Пожалуйста, обратите внимание, что предоставленный код является примером и может потребоваться дополнительная обработка ошибок или проверка ввода данных для обеспечения кор
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
