
Нужно создать программу pascal, вы вводите имя и фамилию и дату рождения в цифрованной форме, а
паскаль переводит месяц в словесном в виде

Ответы на вопрос

условие писать надо понятней




Конечно, я могу помочь вам написать программу на Pascal, которая принимает от пользователя имя, фамилию и дату рождения в цифровой форме, а затем выводит месяц в словесной форме. Вот пример программы:
```pascal program ConvertDateToWords;
var FirstName, LastName: string; BirthDate: string; MonthNumber: integer;
const Months: array[1..12] of string = ('Январь', 'Февраль', 'Март', 'Апрель', 'Май', 'Июнь', 'Июль', 'Август', 'Сентябрь', 'Октябрь', 'Ноябрь', 'Декабрь');
begin // Вводим данные от пользователя writeln('Введите имя: '); readln(FirstName); writeln('Введите фамилию: '); readln(LastName);
writeln('Введите дату рождения в формате ДД.ММ.ГГГГ: '); readln(BirthDate);
// Извлекаем месяц из даты рождения Val(Copy(BirthDate, 4, 2), MonthNumber);
// Проверяем, что месяц в допустимых пределах (от 1 до 12) if (MonthNumber >= 1) and (MonthNumber <= 12) then begin // Выводим результат writeln('Привет, ', FirstName, ' ', LastName, '!'); writeln('Вы родились в ', Months[MonthNumber], '.'); end else writeln('Ошибка: введен некорректный месяц.');
readln; end. ```
В этой программе мы используем массив `Months`, чтобы хранить названия месяцев на русском языке. Мы извлекаем номер месяца из введенной даты рождения, а затем используем его для доступа к соответствующему названию месяца в массиве.
Обратите внимание, что данная программа предполагает, что пользователь вводит дату рождения в формате ДД.ММ.ГГГГ. Если вам нужно обрабатывать другие форматы, вы можете адаптировать код соответственно.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili