
Помогите составить программу решения задачи в паскаль АВС.Дано вещественное число А и целое числоN(
больше 0).Найти А в степени N= А*А*А...*А ( числа А перемножаются N раз)

Ответы на вопрос

var a,rezult:real;
n,i:integer;
begin
writeln('a='); readln(a);
writeln('n='); readln(n);
rezult:=1;
for i:=1 to n do
rezult:=rezult*a;
writeln('rezult=',rezult);
end.



Конечно, я могу помочь вам с составлением программы на языке Pascal для возведения вещественного числа A в степень N. Вот пример кода:
```pascal program ВозведениеВСтепень;
var A, Result: real; N, i: integer;
begin // Ввод вещественного числа A write('Введите вещественное число A: '); readln(A);
// Ввод целого числа N (больше 0) write('Введите целое число N (больше 0): '); readln(N);
// Проверка на корректность введенного N if N <= 0 then begin writeln('Ошибка: N должно быть больше 0.'); exit; end;
// Инициализация результата Result := 1;
// Возведение A в степень N for i := 1 to N do begin Result := Result * A; end;
// Вывод результата writeln('Результат: ', Result); end. ```
Эта программа сначала запрашивает у пользователя вещественное число A и целое число N. Затем она проверяет корректность введенного значения N (должно быть больше 0) и использует цикл для многократного умножения числа A на само себя N раз. Результат выводится на экран.
Обратите внимание, что этот код предполагает, что введенные значения будут корректными. В реальной программе следовало бы добавить дополнительные проверки на корректность ввода (например, что введены действительные числа, а не текст).


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili