Написать программу,которая в одномерном массиве из 15 элементов подсчитывает количество элементов
равных среднеарифметическомуОтветы на вопрос
const
n=15;
var
a:array[1..n]of real;
i,k:integer;
s:real;
begin
for i:=1 to n do
begin
readln(a[i]);
s:=s+a[i];
end;
s:=s/n;
writeln;
clrscr;
for i:=1 to n do
begin
write(a[i]:6:2);
if a[i]=s then
inc(k);
end;
writeln;
if k<>0 then
writeln('k: ',k)
else writeln('Нет равных')
end.
Для решения данной задачи можно написать программу на языке программирования, которая будет подсчитывать количество элементов в одномерном массиве, равных среднеарифметическому.
Вот пример программы на языке C, которая решает данную задачу:
```c
#include
int main() { int arr[15]; int sum = 0; int count = 0; double average;
// Ввод элементов массива printf("Введите 15 элементов массива:\n"); for (int i = 0; i < 15; i++) { scanf("%d", &arr[i]); sum += arr[i]; }
// Вычисление среднеарифметического average = (double)sum / 15;
// Подсчет количества элементов, равных среднеарифметическому for (int i = 0; i < 15; i++) { if (arr[i] == average) { count++; } }
// Вывод результата printf("Количество элементов, равных среднеарифметическому: %d\n", count);
return 0; } ```
Программа запрашивает у пользователя ввод 15 элементов массива, затем вычисляет среднеарифметическое значение и подсчитывает количество элементов, равных этому значению. Результат выводится на экран.
Примечание: В данном примере предполагается, что пользователь будет вводить целочисленные значения элементов массива.
Надеюсь, это поможет вам решить задачу! Если у вас возникнут дополнительные вопросы, пожалуйста, дайте мне знать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
