
Помогите решить задачи по паскалю: 1. модифицируйте предыдущий пример, так чтобы программа
определяла максимальный и минимальный элемент массива 2. Напишите программу, которая бы определяла среднее арифметическое значение элементов массива (вещественная величина типа real) Начало: var a: array[1..10] of integer; i: integer; begin а как дальше?Предыдущий пример:var a: array[1..10] of integer;i: integer;beginrandomize;for i:=1 to 10 dobegina[i]:=random(40)-20;end;for i:=1write(a[i]:4);end.

Ответы на вопрос

n = 10;
var
a: array[1..n] of integer;
i, k, min, max: integer;
begin
randomize;
min := 100; max := -100;
Writeln('исходный массив');
for i := 1 to n do
begin
k := random(40) - 20;
a[i] := n;
if max < k then max := k
else if min > k then min := k;
Write(k, ' ')
end;
Writeln;
Writeln('min=', min, ', max=', max)
end.
Тестовое решение:
исходный массив
-8 3 19 -14 19 13 -17 -2 8 8
min=-17, max=19
---------------------------------------------------------
const
n = 10;
var
a: array[1..n] of integer;
i, k, s: integer;
begin
randomize;
s := 0;
Writeln('исходный массив');
for i := 1 to n do
begin
k := random(40) - 20;
a[i] := n; s := s + k;
Write(k, ' ')
end;
Writeln;
Writeln('Среднее арифметическое равно ', s / k)
end.
Тестовое решение:
исходный массив
19 11 -1 1 -4 -6 -2 18 3 8
Среднее арифметическое равно 5.875



1. Для модификации предыдущего примера и определения максимального и минимального элементов массива, можно использовать следующий код:
var a: array[1..10] of integer; i, max, min: integer;
begin randomize; for i := 1 to 10 do begin a[i] := random(40) - 20; if i = 1 then begin max := a[i]; min := a[i]; end else begin if a[i] > max then max := a[i]; if a[i] < min then min := a[i]; end; end; writeln('Максимальный элемент массива: ', max); writeln('Минимальный элемент массива: ', min); end.
В данном коде мы добавили две переменные max и min, которые будут хранить максимальное и минимальное значения соответственно. При каждой итерации цикла мы сравниваем текущий элемент массива с max и min и обновляем их, если необходимо. В конце программы выводим значения max и min.
2. Для определения среднего арифметического элементов массива можно использовать следующий код:
var a: array[1..10] of integer; i: integer; sum: real; average: real;
begin randomize; sum := 0; for i := 1 to 10 do begin a[i] := random(40) - 20; sum := sum + a[i]; end; average := sum / 10; writeln('Среднее арифметическое значение элементов массива: ', average); end.
В данном коде мы добавили переменную sum, которая будет хранить сумму всех элементов массива. При каждой итерации цикла мы прибавляем текущий элемент массива к sum. В конце программы вычисляем среднее арифметическое значение, разделив sum на количество элементов массива (в данном случае 10). Затем выводим полученное значение.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili