Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате
выведет среднее арифметическое значение введенных чисел (массив не использовать). Сделайте три варианта программы используя операторы цикла While, Repeat и For.Ответы на вопрос
var
a,b,c,i:integer;
begin
i:=0;
b:=0;
writeln('Write 10 number:');
while i<10 do
begin
read(a);
b:=b+a;
i:=i+1;
end;
writeln('Average: ',b/10:0:0);
readln
end.
Программа с использованием оператора цикла While
``` program AverageWhile;
var i, n, sum, count: integer; average: real;
begin sum := 0; count := 0; while count < 10 do begin writeln('Введите число:'); readln(n); sum := sum + n; count := count + 1; end; average := sum / 10; writeln('Среднее арифметическое:', average); end. ```
Программа с использованием оператора цикла Repeat
``` program AverageRepeat;
var i, n, sum, count: integer; average: real; begin sum := 0; count := 0; repeat writeln('Введите число:'); readln(n); sum := sum + n; count := count + 1; until count = 10; average := sum / 10; writeln('Среднее арифметическое:', average); end. ```
Программа с использованием оператора цикла For
``` program AverageFor;
var i, n, sum: integer; average: real; begin sum := 0; for i := 1 to 10 do begin writeln('Введите число:'); readln(n); sum := sum + n; end; average := sum / 10; writeln('Среднее арифметическое:', average); end. ```
В каждой программе компьютер будет запрашивать ввод чисел 10 раз. Затем он вычислит сумму введенных чисел и найдет среднее арифметическое значение, разделив сумму на 10. Результат будет выведен на экран.
Каждая программа использует разный оператор цикла (While, Repeat и For), но выполняет одну и ту же задачу. Вы можете выбрать любую из них в зависимости от вашего предпочтения или требований языка программирования, которым вы пользуетесь.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
