Вопрос задан 11.09.2018 в 15:34.
Предмет Информатика.
Спрашивает Стекольщикова Вита.
Напишите программу нахождения часов, минут и секунд в n суток.
Ответы на вопрос
Отвечает Купяк Маша.
Var n,a,h,m,s:integer;
begin
writeln('Введите кол-во дней');
read(n);
if n>1 then begin
writeln('В ', n ,' сутках:');
writeln(n*24,' часа');
writeln(n*24*60,' минут');
writeln(n*24*60*60,' секунд')
end;
if n=1 then begin
writeln('В ',n,' дне');
writeln(n*24,' часа');
writeln(n*24*60,' минут');
writeln(n*24*60*60,' секунд');
end;
end.
begin
writeln('Введите кол-во дней');
read(n);
if n>1 then begin
writeln('В ', n ,' сутках:');
writeln(n*24,' часа');
writeln(n*24*60,' минут');
writeln(n*24*60*60,' секунд')
end;
if n=1 then begin
writeln('В ',n,' дне');
writeln(n*24,' часа');
writeln(n*24*60,' минут');
writeln(n*24*60*60,' секунд');
end;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Я могу помочь вам написать программу нахождения часов, минут и секунд в n суток. Вот один из возможных вариантов решения этой задачи на языке Python:
```python # Вводим количество суток n n = int(input("Введите количество суток: "))
# Переводим сутки в секунды seconds = n * 24 * 60 * 60
# Находим количество часов, минут и секунд в n сутках hours = seconds // 3600 minutes = (seconds % 3600) // 60 seconds = (seconds % 3600) % 60
# Выводим результат на экран print(f"В {n} сутках {hours} часов, {minutes} минут и {seconds} секунд.") ```
Надеюсь, это было полезно. Если у вас есть другие вопросы, я буду рад ответить.
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
