Составить программу нахождения минимального числа из 2-х чисел
Ответы на вопрос
x,y:integer;
begin
readln (x,y);
if (x <> y) then
if (x<y) then
writeln ('Min = ',x)
else
writeln ('Min = ',y);
end.
Программа нахождения минимального числа из двух чисел может быть написана на различных языках программирования. В данном примере рассмотрим программу на языке Python.
```python # Ввод двух чисел num1 = int(input("Введите первое число: ")) num2 = int(input("Введите второе число: "))
# Сравнение чисел и нахождение минимального if num1 < num2: min_num = num1 else: min_num = num2
# Вывод минимального числа print("Минимальное число:", min_num) ```
В данной программе пользователю предлагается ввести два числа. Затем с помощью условного оператора `if` сравниваются эти числа. Если первое число (`num1`) меньше второго (`num2`), то значение `num1` присваивается переменной `min_num`. В противном случае, значение `num2` присваивается `min_num`. В конце программы выводится найденное минимальное число.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
