
Дан двумерный массив размерностью n*m. Заменить все отрицательные элементы на
противоположные.(помогите составить программу для паскаля).

Ответы на вопрос

const NN=50;
var
a:array [1..NN,1..NN] of integer;
i,j,m,n:integer;
begin
write('Введите n: ');
readln(n);
write('Введите m: ');
readln(m);
for i:= 1 to n do
for j:= 1 to m do
readln(a[i,j]);
for i:= 1 to n do
for j:= 1 to m do
if a[i,j]<0 then a[i,j]:=abs(a[i,j]);
for i:= 1 to n do
begin
for j:= 1 to m do
write(a[i,j],' ');
writeln;
end;
end.



Program a1;
Uses crt;
const n=8;
m=8;
Var a:array[1..n,1..m] of integer;
i,j:byte;
Begin
Writeln('Исходная матрица');
For i:=1 to n do
begin
Writeln;
For j:= 1 to m do
begin
a[i,j]:=random(101)-50;
Write(a[i,j],' ');
end;
end;
Writeln;
Writeln('Отредактированная матрица');
For i:=1 to n do
begin
Writeln;
For j:= 1 to m do
begin
If a[i,j]<0 then a[i,j]:=abs(a[i,j]);
Write(a[i,j],' ');
end;
end;
End.



Вот пример программы на языке Паскаль, которая заменяет все отрицательные элементы двумерного массива на их противоположные значения:
```pascal program ReplaceNegativeElements; const n = 3; // количество строк m = 4; // количество столбцов var arr: array[1..n, 1..m] of integer; // объявление двумерного массива i, j: integer; // переменные для циклов begin // заполнение массива случайными значениями for i := 1 to n do for j := 1 to m do arr[i, j] := random(21) - 10; // случайное число от -10 до 10
// вывод исходного массива writeln('Исходный массив:'); for i := 1 to n do begin for j := 1 to m do write(arr[i, j]:3); writeln; end;
// замена отрицательных элементов на противоположные for i := 1 to n do for j := 1 to m do if arr[i, j] < 0 then arr[i, j] := -arr[i, j];
// вывод измененного массива writeln('Массив после замены:'); for i := 1 to n do begin for j := 1 to m do write(arr[i, j]:3); writeln; end;
readln; end. ```
В данной программе используется двумерный массив `arr` размерностью `n` на `m`. Сначала массив заполняется случайными значениями от -10 до 10. Затем происходит замена отрицательных элементов на их противоположные значения. После этого выводятся исходный и измененный массивы.
Пример вывода программы:
``` Исходный массив: -2 -4 6 -5 9 -1 2 3 8 -9 1 -7 Массив после замены: 2 4 6 5 9 1 2 3 8 9 1 7 ```


Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili