
1) составить программу(паскаль) вывода на экран трёхзначных нечётных чисел которые оканчиваются на
3 2) составить программу последов. чисел целых чисел определить наименьшее четное отрицательное число. О признак окончания ввода ( min = 30.000 ) 3) последов. целых чисел найти среднее арифметических чётных чисел. О- признак окончания ввода ( integer, k 10000 ) s/n

Ответы на вопрос

//1
begin
for var i:=100 to 999 do if i mod 10 = 3 then print (i);
end.
//2
begin
var min:=30000; var n:=0;
repeat
n:=readinteger('Введите число: ');
if (n.iseven) and (n<0) and (n<min) then min:=n;
until n=0;
write ('Min: ', min);
end.
//3
begin
var sum:=0; var n:=0; var a:=0;
repeat
a:=readinteger('Введите число: ');
if a.iseven then
begin
sum+=a;
inc (n);
end;
until a=0;
write ('Average: ',sum/(n-1));
end.



Программа вывода на экран трехзначных нечетных чисел, которые оканчиваются на 3
```pascal program ThreeDigitOddNumbers; var number: integer; begin for number := 103 to 999 step 10 do begin writeln(number); end; end. ```
Объяснение программы: - Мы используем цикл `for` для перебора чисел от 103 до 999 с шагом 10. Это гарантирует, что мы получим только трехзначные числа, которые оканчиваются на 3 и являются нечетными. - Внутри цикла мы используем `writeln` для вывода каждого числа на экран.
Программа для определения наименьшего четного отрицательного числа
```pascal program SmallestNegativeEvenNumber; var number, min: integer; begin min := 30; repeat readln(number); if (number < min) and (number mod 2 = 0) then begin min := number; end; until number = 0; writeln('The smallest negative even number is: ', min); end. ```
Объяснение программы: - Мы используем цикл `repeat...until` для ввода последовательности целых чисел. - Переменная `min` инициализируется значением 30, так как это значение будет заменено, если будет найдено более маленькое четное отрицательное число. - Внутри цикла мы сравниваем каждое введенное число с текущим значением `min`. Если число меньше `min` и является четным, мы обновляем значение `min`. - Цикл продолжается до тех пор, пока не будет введено число 0. - После окончания цикла, мы выводим наименьшее отрицательное четное число на экран.
Программа для нахождения среднего арифметического четных чисел
```pascal program AverageOfEvenNumbers; var number, sum, count: integer; begin sum := 0; count := 0; repeat readln(number); if number mod 2 = 0 then begin sum := sum + number; count := count + 1; end; until number = 0; if count > 0 then begin writeln('The average of even numbers is: ', sum / count); end else begin writeln('No even numbers were entered.'); end; end. ```
Объяснение программы: - Мы используем цикл `repeat...until` для ввода последовательности целых чисел. - Переменные `sum` и `count` инициализируются нулевыми значениями. `sum` будет использоваться для суммирования четных чисел, а `count` - для подсчета количества четных чисел. - Внутри цикла мы проверяем, является ли введенное число четным. Если да, то мы добавляем его к сумме и увеличиваем счетчик на 1. - Цикл продолжается до тех пор, пока не будет введено число 0. - После окончания цикла, мы проверяем, были ли введены четные числа. Если да, то выводим их среднее арифметическое на экран. Если нет, то выводим сообщение о том, что четные числа не были введены.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili