Вопрос задан 28.08.2018 в 05:04. Предмет Информатика. Спрашивает Тратас Ульяна.

Составить программу на языке Паскаль, Больше из двух чисел увеличить на единицу, Меньшее увеличить

в два раза. 8 класс срочно
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Джевахашвили Маргарита.
Var a, b: integer;
begin
readln(a, b);
if a> b then begin
b:=b*2;
a:= a+1;
end
else
a:=a*2;
b:=b+1;
writeln(a,' ',b);
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Pascal, которая выполняет заданное условие: увеличивает большее из двух чисел на единицу, а меньшее число увеличивает в два раза.

```pascal program IncreaseNumbers;

var num1, num2, bigger, smaller: integer;

begin writeln('Введите первое число: '); readln(num1); writeln('Введите второе число: '); readln(num2);

// Определяем большее и меньшее число if num1 > num2 then begin bigger := num1; smaller := num2; end else begin bigger := num2; smaller := num1; end;

// Увеличиваем большее число на единицу bigger := bigger + 1;

// Увеличиваем меньшее число в два раза smaller := smaller * 2;

writeln('Большее число увеличено на единицу: ', bigger); writeln('Меньшее число увеличено в два раза: ', smaller);

end. ```

Программа сначала запрашивает у пользователя два числа (num1 и num2), затем определяет, какое из них больше и какое меньше. Затем она увеличивает большее число на единицу и удваивает меньшее число. Результаты выводятся на экран.

Обратите внимание, что программа предполагает ввод целочисленных значений.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос