Вопрос задан 24.08.2018 в 17:31. Предмет Информатика. Спрашивает Базилюк Альоша.

Срочно!! Помогите написать программу в турбо паскале!!Огромное человеческое спасибо!!Заполнить

массив из 10 элементов случайными числами в интервалеот-50 до 50 и отсортировать его по убыванию с помощью алгоритма быстрой сортировки.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Московченко Надежда.

const low=1; high=10;

procedure qSort(var ar:array[low..high]of real; low,high:integer);
var i,j:integer;
m,wsp:real;
begin
i:=low;
j:=high;
m:=ar[(i+j) div 2];
repeat
while(ar[i]<m) do i:=i+1;
while(ar[j]>m) do j:=j-1;
if(i<=j) then begin
wsp:=ar[i];
ar[i]:=ar[j];
ar[j]:=wsp;
i:=i+1;
j:=j-1;
end;
until (i > j);
if(low<j) then qSort(ar,low,j);
if(i<high) then qSort(ar,i,high);
end;

var ar:array[low..high]of real;
i:integer;
begin
randomize;

for i:=low to high do ar[i]:=random(101)-50;
qSort(ar,low,high);
writeln;
for i:=low to high do write(ar[i],' ');
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Turbo Pascal, которая заполняет массив из 10 элементов случайными числами в интервале от -50 до 50 и сортирует его по убыванию с помощью алгоритма быстрой сортировки:

```pascal program QuickSortExample;

const N = 10; // Размер массива

type TArray = array[1..N] of integer;

var arr: TArray;

procedure FillArrayRandom(var arr: TArray); var i: integer; begin Randomize; // Инициализация генератора случайных чисел for i := 1 to N do arr[i] := Random(101) - 50; // Генерация случайного числа от -50 до 50 end;

procedure QuickSort(var arr: TArray; Left, Right: integer); var i, j, Pivot, Temp: integer; begin if Left < Right then begin Pivot := arr[(Left + Right) div 2]; i := Left; j := Right; while i <= j do begin while arr[i] > Pivot do Inc(i); while arr[j] < Pivot do Dec(j); if i <= j then begin Temp := arr[i]; arr[i] := arr[j]; arr[j] := Temp; Inc(i); Dec(j); end; end; QuickSort(arr, Left, j); QuickSort(arr, i, Right); end; end;

procedure PrintArray(arr: TArray); var i: integer; begin for i := 1 to N do Write(arr[i], ' '); Writeln; end;

begin FillArrayRandom(arr); Writeln('Исходный массив:'); PrintArray(arr); QuickSort(arr, 1, N); Writeln('Отсортированный массив по убыванию:'); PrintArray(arr); end. ```

Эта программа использует рекурсивный алгоритм быстрой сортировки для сортировки массива по убыванию. `FillArrayRandom` заполняет массив случайными числами в интервале от -50 до 50, `QuickSort` выполняет сортировку, а `PrintArray` выводит содержимое массива.

Просто скопируйте этот код в среду программирования Turbo Pascal и запустите его. Он выведет исходный массив и отсортированный массив по убыванию.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос