Составьте программу. Даны 6 чисел, найти среднее арифметическое. Помогите пожалуйста)
Ответы на вопрос
a,sum,sr: real;
i: integer;
begin
sum:=0;
for i:=1 to 6 do
begin
writeln ('введи число');
read (a);
sum:=sum+a;
end;
sr:=sum/6;
writeln ('среднее арифметическое равно',sr);
end.
Для решения данной задачи можно написать программу на языке программирования, которая будет находить среднее арифметическое из шести заданных чисел. Вот пример программы на языке C++:
```cpp
#include
int main() { int num1, num2, num3, num4, num5, num6; double average;
// Ввод шести чисел std::cout << "Введите шесть чисел: "; std::cin >> num1 >> num2 >> num3 >> num4 >> num5 >> num6;
// Вычисление среднего арифметического average = (num1 + num2 + num3 + num4 + num5 + num6) / 6.0;
// Вывод результата std::cout << "Среднее арифметическое: " << average << std::endl;
return 0; } ```
Эта программа сначала запрашивает у пользователя ввод шести чисел, а затем вычисляет и выводит их среднее арифметическое.
Примечание: При написании программы следует учесть, что она может быть адаптирована для разных языков программирования.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
