Вопрос задан 20.08.2018 в 17:41. Предмет Информатика. Спрашивает Сикальчук София.

Помогите пожалуста составить программу в С++: 1. Записать собственную функцию вычисления модуля

числа n modul (n) и использовать ее для вычисления среднего арифметического модулей трех произвольных чисел. 2. Создать функцию для вычисления длины отрезка, заданного координатами своих вершин на плоскости. Использовать эту функцию для вычисления периметра треугольника, заданного координатами своих вершин.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Пономарцов Егор.
#include <iostream>
#include <ctime>
#include <cmath>

using namespace std;

struct VERT // структура для вершины многоугольника
{
  int x;
  int y;
};

// Модуль числа
int Modul( int a )
{
  return (a > 0 ? a : -a);
}

// Длина отрезка через координаты
float Len( int x1, int y1, int x2, int y2 )
{
  return sqrt((x1 - x2) * (x1 - x2) + (y1 - y2) * (y1 - y2));
}

int main ()
{
  /// ---- ЗАДАНИЕ 1 ---- ///
  const int N = 3;
  int arr[N];
  float mid = 0;

  // Установка "зерна" для случайных чисел
  srand(time(NULL));
  // Заполнение массива случайными числами и суммирование
  for (int i = 0; i < N; i++)
    arr[i] = rand() % 100, mid += Modul(arr[i]);

  // Вычисление среднего арифм.
  mid /= M;

  /// ---- ЗАДАНИЕ 2 ---- ///
  
  const int V = 3; // количество вершин многоугольника
  VERT vert[V]; // массив вершин многоугольника

  cout << "Введите координаты вершин (x y): " << endl;
  for (int i = 0; i < V; i++)
  {
    cout << i + 1 << ": ";
    cin >> vert[i].x >> vert[i].y;
  }

  // Вычисление периметра
  float per = 0;
  for (int i = 0; i < V - 1; i++)
    per += Len(vert[i].x, vert[i].y, vert[i + 1].x, vert[i + 1].y);

  cout << "Периметр = " << per << endl;

  return 0;
}


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Составление программы в C++

Для начала, давайте создадим функцию для вычисления модуля числа и затем используем ее для вычисления среднего арифметического модулей трех произвольных чисел. Затем создадим функцию для вычисления длины отрезка, заданного координатами своих вершин на плоскости, и используем эту функцию для вычисления периметра треугольника, заданного координатами своих вершин.

```cpp #include #include // Для использования функции abs() (вычисление модуля числа)

// Функция для вычисления модуля числа double modul(int n) { return abs(n); // Используем функцию abs() для вычисления модуля числа }

// Функция для вычисления среднего арифметического модулей трех чисел double averageModuls(int a, int b, int c) { return (modul(a) + modul(b) + modul(c)) / 3.0; // Вычисляем среднее арифметическое модулей }

// Функция для вычисления длины отрезка по координатам его вершин double lengthOfSegment(int x1, int y1, int x2, int y2) { return sqrt(pow(x2 - x1, 2) + pow(y2 - y1, 2)); // Формула вычисления длины отрезка }

// Функция для вычисления периметра треугольника по координатам его вершин double perimeterOfTriangle(int x1, int y1, int x2, int y2, int x3, int y3) { double side1 = lengthOfSegment(x1, y1, x2, y2); double side2 = lengthOfSegment(x2, y2, x3, y3); double side3 = lengthOfSegment(x3, y3, x1, y1); return side1 + side2 + side3; // Вычисляем периметр треугольника }

int main() { // Пример использования функций int num1 = -5, num2 = 8, num3 = -3; std::cout << "Среднее арифметическое модулей чисел " << num1 << ", " << num2 << ", " << num3 << " равно " << averageModuls(num1, num2, num3) << std::endl;

int x1 = 0, y1 = 0, x2 = 3, y2 = 4, x3 = 6, y3 = 0; std::cout << "Периметр треугольника с вершинами (" << x1 << "," << y1 << "), (" << x2 << "," << y2 << "), (" << x3 << "," << y3 << ") равен " << perimeterOfTriangle(x1, y1, x2, y2, x3, y3) << std::endl;

return 0; } ```

В данной программе мы создали функции для вычисления модуля числа, среднего арифметического модулей трех чисел, длины отрезка по координатам его вершин и периметра треугольника по координатам его вершин. В функции `main` мы привели примеры использования этих функций.

Примечание: Пожалуйста, убедитесь, что вы используете среду разработки C++ для компиляции и запуска данной программы.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос