Информатика.Паскаль.Задача.Известны координаты вершин A,B,C треугольника.Составить программу в
паскале,вычисляющую площадь этого треугольника.Где:xa=2,ya=1,xb=6,yb=5,xc=10,yc=1Ответы на вопрос
begin
readln(xa,ya,xb,yb,xc,yc);
S:=abs(((xb-xa)*(yc-ya)-(xc-xa)*(yb-ya))/2);
writeln(s);
readln;
end.
На паскале проверил, все отлично работает!:)
Для вычисления площади треугольника по его координатам можно воспользоваться формулой Герона. Формула Герона выглядит следующим образом:
S = sqrt(p * (p - a) * (p - b) * (p - c))
где S - площадь треугольника, p - полупериметр треугольника, a, b, c - длины его сторон.
Для начала, нам необходимо вычислить длины сторон треугольника по его координатам. Для этого можно воспользоваться формулой вычисления расстояния между двумя точками на плоскости:
d = sqrt((x2 - x1)^2 + (y2 - y1)^2)
где d - расстояние между точками (x1, y1) и (x2, y2).
В нашем случае, стороны треугольника будут равны:
a = sqrt((xb - xa)^2 + (yb - ya)^2) b = sqrt((xc - xb)^2 + (yc - yb)^2) c = sqrt((xa - xc)^2 + (ya - yc)^2)
После вычисления длин сторон, можно вычислить полупериметр треугольника:
p = (a + b + c) / 2
И, наконец, вычислить площадь треугольника:
S = sqrt(p * (p - a) * (p - b) * (p - c))
Вот пример программы на языке Pascal, реализующей вычисление площади треугольника по его координатам:
```pascal program TriangleArea;
uses math;
var xa, ya, xb, yb, xc, yc: real; a, b, c, p, S: real;
begin xa := 2; ya := 1; xb := 6; yb := 5; xc := 10; yc := 1;
a := sqrt(sqr(xb - xa) + sqr(yb - ya)); b := sqrt(sqr(xc - xb) + sqr(yc - yb)); c := sqrt(sqr(xa - xc) + sqr(ya - yc));
p := (a + b + c) / 2; S := sqrt(p * (p - a) * (p - b) * (p - c));
writeln('Площадь треугольника: ', S:0:2); end. ```
После выполнения программы на экран будет выведено значение площади треугольника, округленное до двух знаков после запятой.
Надеюсь, это поможет вам решить задачу!
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
