Вопрос задан 09.08.2018 в 06:29.
Предмет Информатика.
Спрашивает Березина Дарья.
Помогите, пожалуйста, написать программу на Паскале!!!! Срочно.Вариант 3

Ответы на вопрос
Отвечает Забелина Алла.
PascalABC.NET 3.3.5, сборка 1644 от 23.03.2018
Внимание! Если программа не работает, обновите версию!
№1
begin
Writeln(' a b x z');
foreach var a in 0.55.Step(0.55).TakeWhile(t->t<=5.5) do begin
var b:=a<=2?a/2:2*a;
var x:=a+0.3;
var z:=a*Sin(x)+b*Cos(x);
Writeln(a:4:2,b:8:2,x:8:2,z:12:6)
end
end.
№2
begin
var a:=new string[4](' *',' * *',' * *','* *');
(a+a[:4].Reverse).PrintLines
end.
Внимание! Если программа не работает, обновите версию!
№1
begin
Writeln(' a b x z');
foreach var a in 0.55.Step(0.55).TakeWhile(t->t<=5.5) do begin
var b:=a<=2?a/2:2*a;
var x:=a+0.3;
var z:=a*Sin(x)+b*Cos(x);
Writeln(a:4:2,b:8:2,x:8:2,z:12:6)
end
end.
№2
begin
var a:=new string[4](' *',' * *',' * *','* *');
(a+a[:4].Reverse).PrintLines
end.


Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
