Вопрос задан 08.08.2018 в 12:38. Предмет Информатика. Спрашивает Барсова Екатерина.

Написать программу для вычисления периметра прямоугольного треугольника по двум катетам.По

программе Паскаль.Помогите пж.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Хмызова Алёна.
S=a*b
P=(a+b)*2
это или нет
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Pascal для вычисления периметра прямоугольного треугольника по двум катетам

Вот пример программы на языке Pascal, которая вычисляет периметр прямоугольного треугольника по двум катетам:

```pascal program PerimeterOfRightTriangle;

var cathetus1, cathetus2, hypotenuse, perimeter: real;

begin writeln('Введите длину первого катета: '); readln(cathetus1); writeln('Введите длину второго катета: '); readln(cathetus2); // Вычисление гипотенузы с использованием теоремы Пифагора hypotenuse := sqrt(cathetus1 * cathetus1 + cathetus2 * cathetus2); // Вычисление периметра perimeter := cathetus1 + cathetus2 + hypotenuse; writeln('Периметр прямоугольного треугольника: ', perimeter); readln; end. ```

В этой программе мы сначала запрашиваем у пользователя длину двух катетов. Затем мы используем теорему Пифагора для вычисления длины гипотенузы. Наконец, мы вычисляем периметр, складывая длины всех трех сторон. Результат выводится на экран.

Примечание: В данном примере используется встроенная функция `sqrt` для вычисления квадратного корня. Эта функция может быть доступна в различных реализациях языка Pascal. Если ваш компилятор не поддерживает эту функцию, вам может потребоваться написать свою собственную функцию для вычисления квадратного корня.

Надеюсь, эта программа поможет вам вычислить периметр прямоугольного треугольника по двум катетам. Если у вас возникнут еще вопросы, не стесняйтесь задавать их!

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос