Вопрос задан 08.08.2018 в 04:52.
Предмет Информатика.
Спрашивает Иванютин Влад.
Составить программу. которая меньше из двух чисел заменяет их полусуммой а большее их
произведением. во вложении образец как нужно делать
Ответы на вопрос
Отвечает Акетай Аружан.
Блок-схема - в прилагаемом файле.
var a,b,c,d:real;
begin
write('a, b: ');
readln(a,b);
c:=(a+b)/2;
d:=2*a*b;
if a<b
then begin a:=c; b:=d; end
else begin a:=d; b:=c; end;
writeln('a = ',a,' b = ',b);
end.
Пример:
a, b: 8 5
a = 80 b = 6.5
var a,b,c,d:real;
begin
write('a, b: ');
readln(a,b);
c:=(a+b)/2;
d:=2*a*b;
if a<b
then begin a:=c; b:=d; end
else begin a:=d; b:=c; end;
writeln('a = ',a,' b = ',b);
end.
Пример:
a, b: 8 5
a = 80 b = 6.5

Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
