
Нужно написать программу на PascalABC Напишите программу, которая в последовательности натуральных
чисел определяет сумму чисел, оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 4. Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число-сумму чисел, оканчивающихся на 4. Пример работы программы: Входные данные: 3 14 25 24 Выходные данные 38

Ответы на вопрос

begin
writeln('Сколько чисел в последовательности?');
readln(n);
for var i:=1 to n do begin
k:=random(1,30000);
write(k:6);
if k mod 10 = 4 then s:=s+k;
if i mod 10 = 0 then writeln;
end;
writeln();
writeln('Сумма чисел, заканчивающихся на 4: ',s);
end.



Программа на PascalABC++ для решения этой задачи может выглядеть следующим образом:
```pascal program SumOfNumbers; var n, i, number, sum: integer; begin sum := 0; // инициализация переменной суммы readln(n); // считываем количество чисел for i := 1 to n do begin readln(number); // считываем число if number mod 10 = 4 then // проверяем, оканчивается ли число на 4 sum := sum + number; // если да, то добавляем его к сумме end; writeln(sum); // выводим сумму чисел, оканчивающихся на 4 end. ```
Программа сначала считывает количество чисел `n` в последовательности. Затем в цикле `for` проходит по каждому числу и проверяет, оканчивается ли оно на 4. Если да, то число добавляется к сумме `sum`. После завершения цикла программа выводит полученную сумму.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili