Написать программу,которая запросит у пользователя два числа и одине из знаков : + - * / и выведет
на экран результат соответствующего арифметического действия. Помогите пожалуйста.СРОЧНООтветы на вопрос
var a,b:real;
c:char;
begin
read(a,b,c);
if c='+' then writeln(a+b) else
if c='-' then writeln(a-b) else
if c='*' then writeln(a*b) else
if c='/' then writeln(a/b) else
writeln('символ не арифметического действия');
end.
Конечно, я могу помочь вам написать программу, которая будет запрашивать у пользователя два числа и один из знаков арифметической операции (+, -, *, /), а затем выводить на экран результат соответствующего арифметического действия. Вот пример такой программы на языке Python:
```python # Запрос чисел и оператора у пользователя num1 = float(input("Введите первое число: ")) num2 = float(input("Введите второе число: ")) operator = input("Введите оператор (+, -, *, /): ")
# Выполнение арифметической операции и вывод результата if operator == "+": result = num1 + num2 elif operator == "-": result = num1 - num2 elif operator == "*": result = num1 * num2 elif operator == "/": result = num1 / num2 else: print("Некорректный оператор!")
print("Результат:", result) ```
В этой программе мы сначала запрашиваем у пользователя два числа и оператор с помощью функции `input()`. Затем мы используем условные операторы `if-elif-else` для выполнения соответствующей арифметической операции в зависимости от введенного оператора. Результат операции сохраняется в переменной `result` и выводится на экран с помощью функции `print()`.
Примечание: В этом примере предполагается, что пользователь будет вводить только числа и один из четырех допустимых операторов. Если пользователь вводит что-то другое, программа выведет сообщение "Некорректный оператор!".
Надеюсь, это поможет вам! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
