Напишите программу в PascalAbc которая на вход получает 3 вещественных числа и выводит на экран
большее из них.Ответы на вопрос
x,y,z:real;
begin
writeln('Введите три числа');
read(x,y,z);
If (x>z) and (x>y) then
writeln('Наибольшее= ',x);
If (y>z) and (y>x) then
writeln('Наибольшее= ',y);
If (z>x) and (z>y) then
writeln('Наибольшее= ',z);
If (z=y) and (y=x) then writeln('Все числа одинаковые') else
begin
If (z=x) then writeln('числа x и z равны');
If (y=x) then writeln('числа x и y равны');
If (z=y) then writeln('числа y и z равны');
end;
end.
Конечно! Вот пример программы на PascalABC, которая принимает 3 вещественных числа и выводит на экран наибольшее из них:
```pascal program FindMax;
var num1, num2, num3, max: real;
begin writeln('Введите первое число: '); readln(num1); writeln('Введите второе число: '); readln(num2); writeln('Введите третье число: '); readln(num3); if (num1 >= num2) and (num1 >= num3) then max := num1 else if (num2 >= num1) and (num2 >= num3) then max := num2 else max := num3; writeln('Наибольшее число: ', max); readln; end. ```
В этой программе мы используем переменные `num1`, `num2` и `num3`, чтобы принять ввод от пользователя. Затем мы сравниваем эти числа с помощью условных операторов `if` и `else if`, чтобы найти наибольшее число. Наконец, мы выводим наибольшее число на экран с помощью функции `writeln`.
Надеюсь, это поможет вам! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
