Вопрос задан 01.08.2018 в 21:07. Предмет Информатика. Спрашивает Городницкий Михаил.

Составьте программу в паскале со всеми строчками!!! Хозяин хочет оклеить обоями длинную стену в

своем доме. Длина этой стены равна А метров, а высота - В метров. Рулон обоев имеет длину 12 метров и ширину K см. Составьте алгоритм и программу, которая определит стоимость обоев для всей стены, если цена одного рулона C руб.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Варфоломеев Михаил.
Var a,b,k,c: real; n: integer;
begin
readln(a,b,k,c);
n:=round((a*b)/(12*k/100)+0.5);
writeln(n*c:5:2);
end.

Пример:
5 4 80 120
360.00

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Паскаль:

```pascal program CalculateWallpaperCost;

var A, B, K, C: real; totalWallArea, rollsNeeded, totalCost: real;

begin write('Введите длину стены (в метрах): '); readln(A); write('Введите высоту стены (в метрах): '); readln(B); write('Введите ширину рулона обоев (в сантиметрах): '); readln(K); write('Введите цену одного рулона обоев (в рублях): '); readln(C);

totalWallArea := A * B; rollsNeeded := totalWallArea / (12 * (K/100)); totalCost := rollsNeeded * C;

writeln('Общая площадь стены: ', totalWallArea:0:2, ' кв.м'); writeln('Необходимое количество рулонов обоев: ', rollsNeeded:0:2); writeln('Стоимость обоев для всей стены: ', totalCost:0:2, ' руб'); end. ```

Эта программа позволяет пользователю ввести длину и высоту стены, ширину рулона обоев и цену одного рулона обоев. Затем программа рассчитывает общую площадь стены, необходимое количество рулонов обоев и общую стоимость обоев для всей стены.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос