ПОМОГИТЕ ПОЖАЛУЙСТА!!!!!!!!!!!Напишите программу для решения следующей задачи. На контрольной
работе по алгебре ученикам 9 класса было предложено 10 примеров. Неудовлетворительная оценка выставляется, если правильно решено менее половины примеров. Сколько неудовлетворительных оценок было получено учениками? Если хотя бы один из учеников правильно решил все задачи, выведите YES, иначе выведите NO. Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых примеров.ЯЗЫК С+++Ответы на вопрос
Ответ:
var a,b,c,d,e:integer;
begin
d:=1;
e:=0;
writeln('введите количество учеников');
readln(a);
for b:=1 to a do begin
writeln('введите количество правильных ответов для ',d,' ученика' );
readln(c);
while (c>10) or (c<0) do begin
writeln('вы ввели неверное число, попробуйте снова');
readln(c);
end;
if c = 10 then e:=e+1;
d:=d+1;
end;
if (e>=1) then writeln('yes ')
else writeln('no');
end.
Объяснение:
Я могу помочь вам с написанием программы на языке С++. Вот один из возможных вариантов решения вашей задачи:
```c++
#include
int main() { // Вводим количество учеников в классе N int N; cin >> N;
// Проверяем, что N в допустимом диапазоне if (N < 1 || N > 30) { cout << "Неверное значение N" << endl; return 0; }
// Создаем переменные для подсчета неудовлетворительных оценок и учеников, решивших все задачи int bad_grades = 0; int all_solved = 0;
// В цикле для каждого ученика вводим количество правильно решенных примеров for (int i = 0; i < N; i++) { int solved; cin >> solved;
// Проверяем, что solved в допустимом диапазоне if (solved < 0 || solved > 10) { cout << "Неверное значение solved" << endl; return 0; }
// Если solved меньше половины от 10, то увеличиваем счетчик неудовлетворительных оценок if (solved < 5) { bad_grades++; }
// Если solved равно 10, то увеличиваем счетчик учеников, решивших все задачи if (solved == 10) { all_solved++; } }
// Выводим результаты cout << "Количество неудовлетворительных оценок: " << bad_grades << endl; if (all_solved > 0) { cout << "YES" << endl; } else { cout << "NO" << endl; }
return 0; } ```
Надеюсь, это поможет вам. Удачи!
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
