Дан массив из 20 целых чисел. Определите, сколько элементов этого массива имеют максимальное
значение.Ответы на вопрос
Ответ:
program average;
const n=20;
var max:integer;//макс. элемент массива
count:integer;//кол-во эл-тов массива,равные максимальному
m:array[1..n] of integer; //массив из 20 целых чисел
i:byte; //счетчик цикла
begin
count:=0; max:=0;
writeln('Введите в строку 20 чисел');
for i:=1 to n do begin
read(m[i]);//считываем в цикле 20 чисел
if (m[i]>max) then max:=m[i]; //если эл-т массива больше максимальнго, то он сам становится максимальным
end;
//перебираем массив в цикле
for i:=1 to n do
if (m[i]=max) then count:=count+1;//если элемент массива равен максимальному, то счетчик таких чисел увеличиваем на 1
//вывод на экран требуемого значения
writeln(count);
end.
Объяснение:
объяснение в комментариях к строкам кода
Для определения количества элементов в массиве, имеющих максимальное значение, необходимо пройти по всем элементам массива и сравнить их со значением максимального элемента. Если элемент равен максимальному значению, увеличиваем счетчик на единицу.
Алгоритм:
1. Инициализируем переменную `maxValue` значением первого элемента массива. 2. Инициализируем переменную `count` значением 0. 3. Проходим по всем элементам массива. 4. Если текущий элемент равен `maxValue`, увеличиваем `count` на единицу. 5. Если текущий элемент больше `maxValue`, обновляем значение `maxValue` и сбрасываем `count` в 1. 6. По окончании цикла, значение `count` будет содержать количество элементов массива с максимальным значением.Пример кода на JavaScript:
```javascript function countMaxElements(arr) { let maxValue = arr[0]; let count = 0;
for (let i = 0; i < arr.length; i++) { if (arr[i] === maxValue) { count++; } else if (arr[i] > maxValue) { maxValue = arr[i]; count = 1; } }
return count; }
const array = [2, 3, -8, -1, 2, 4, -2, 3]; const maxElementsCount = countMaxElements(array); console.log("Количество элементов с максимальным значением:", maxElementsCount); ```
В данном примере массив содержит 20 элементов, но для определения количества элементов с максимальным значением используется другой массив `[2, 3, -8, -1, 2, 4, -2, 3]`. Результат выполнения кода будет выводиться в консоль и будет содержать количество элементов с максимальным значением.
Примечание: Для выполнения данной задачи необходимо знание языка программирования, в данном случае JavaScript. Если у вас возникнут вопросы по коду или его выполнению, я с радостью помогу вам разобраться.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
